XING Help Center

Here you’ll find answers to your questions, and information about XING features. You can also contact the XING Support team (available in English and German) if you need any other assistance.

By the way, we've published some help videos that may be of use to you: Go to videos

Which version of Outlook do I need to install the Outlook Connector?

The Outlook Connector is compatible with Outlook 2003 and higher. You will need to be running Windows XP, Vista, 7 or 8.